PHP Compatibility Checker

Actieve installaties: 300.000+

Buy product
Category: Tag:

Omschrijving

De WP Engine PHP Compatibility Checker kan gebruikt worden voor iedere WordPress site op iedere webhost om de compatibiliteit van de PHP versie te controleren.

Deze plugin zal thema- en plugincode in je WordPress bestandssysteem uitpluizen en je een rapportage verstrekken van compatibiliteitsproblemen die opgelost moeten worden. Compatibiliteitsproblemen worden gecategoriseerd als fouten en waarschuwingen en geven bestandsnaam en plaats van de betreffende codering aan en de reden waarom de code niet compatibel is met de gekozen versie van PHP. De plugin zal updates van thema’s en plugins voorstellen omdat een nieuwere versie ervan wel compatibele code kan bevatten.

Deze plugin voert de code van je thema en plugin niet uit en kan daarom geen runtime compatibiliteitsproblemen ontdekken.

Houd er rekening mee dat de code niet perfect is. Deze plugin kan geen ongebruikte coderingspaden ontdekken die mogelijk gebruikt worden voor achterwaartse compatibiliteit en derhalve zgn. valse positieven kunnen weergeven. We onderhouden een witboek van plugins die valse positieven kunnen veroorzaken. We werken er constant aan om ervoor te zorgen dat de checker voor de hoogst mogelijk accurate resultaten zorgt.

Deze plugin vertrouwt WP-Cron toe bestanden in the background te scannen. De scan kan vastlopen als WP-Cron van de site niet correct loopt. Raadpleeg FAQ voor meer informatie.

Update naar PHP 7.3

  • Gebruik deze plugin om je site te controleren op compatibiliteit tot en met PHP 7.3!
  • Volgens July 2019, draait 20.1% van WordPress websites met een PHP versie ouder dan PHP 5.6.
  • Deze versies van PHP zijn verouderd en niet meer ondersteund voor meer dan 2 jaar.
  • Slechts 54.1% van de WordPress sites draaien met PHP 7, de huidige gangbare versie van PHP.

Disclaimer

Hoewel deze plugin is geschreven om zoveel mogelijk problemen zo accuraat mogelijk te ontdekken is 100% betrouwbare ontdekking erg moeilijk te verwezenlijken. Uitvoering van uitgebreide tests wordt aanbevolen alvorens te migreren naar een nieuwe PHP versie.

De plugin is ontwikkeld door WP Engine om de WordPress community te helpen de adoptie van moderne PHP versies uit te breiden. We welcome contributorsverwelkomen bijdragers voor deze plugin, en zijn opgewonden nieuwsgierig te vernemen hoe ontwikkelaars en andere WordPress hosts deze plugin gebruiken.

Voor informatie over veiligheidskwesties voor deze plugin email s.v.p. WordPress@wpengine.com
PHP Compatibility Checker bevat WP-CLI command ondersteuning:

wp phpcompat  [--scan=]



    PHP version to test.

[--scan=]
  Whether to scan only active plugins and themes or all of them.
  default: active
  options:
    - active
    - all

Voorbeeld: wp phpcompat 7.2 --scan=active

Main Menu